using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*@\w*.\w*)";
string input = @"email me! john@smith.com
e:john@smith.com m:555-555-5555
john@smith.com--personal email";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}