re = /(\w*@\w*.\w*)/
str = 'email me! john@smith.com
e:john@smith.com m:555-555-5555
john@smith.com--personal email'
# Print the match result
str.match(re) do |match|
puts match.to_s
end