import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<tag>(?:[a-zA-Z]\\w*|_\\w+))(?<memspec>(?:(?:(?:\\s*\\.(?:[a-zA-Z]\\w*|_\\w+)|(?:\\s*\\[(?:[^,\\]]+)(?:,(?:[^,\\]]+))*\\]))*)(?:(?:\\s*\\.\\d+|\\.\\s*(?:\\s*\\[(?:[^,\\]]+)\\]))?)))?(?<metadataspec>(?:\\s*\\.\\@(?<metadataid>(?:[a-zA-Z]\\w*|_\\w+))(?<metadatamemspec>(?:(?:(?:\\s*\\.(?:[a-zA-Z]\\w*|_\\w+)|(?:\\s*\\[(?:[^,\\]]+)(?:,(?:[^,\\]]+))*\\]))*)(?:(?:\\s*\\.\\d+|\\.\\s*(?:\\s*\\[(?:[^,\\]]+)\\]))?)))?))?$";
final String string = "tag\n"
+ "tag.mem\n"
+ "tag.1\n"
+ "tag.[0]\n"
+ "tag[0]\n"
+ "tag[0].mem\n"
+ "tag[0].1\n"
+ "tag[0].[0]\n"
+ "tag.mem\n"
+ "tag.mem.mem\n"
+ "tag.mem.1\n"
+ "tag.mem.[0]\n"
+ "tag.mem[0]\n"
+ "tag.mem[0].mem\n"
+ "tag.mem[0].1\n"
+ "tag.mem[0].[0]\n\n"
+ "tag.@foo.mem[0].[0]\n"
+ "tag.mem.@foo.mem[0].[0]\n"
+ "tag.1.@foo.mem[0].[0]\n"
+ "tag.[0].@foo.mem[0].[0]\n"
+ "tag[0].@foo.mem[0].[0]\n"
+ "tag[0].mem.@foo.mem[0].[0]\n"
+ "tag[0].1.@foo.mem[0].[0]\n"
+ "tag[0].[0].@foo.mem[0].[0]\n"
+ "tag.mem.@foo.mem[0].[0]\n"
+ "tag.mem.mem.@foo.mem[0].[0]\n"
+ "tag.mem.1.@foo.mem[0].[0]\n"
+ "tag.mem.[0].@foo.mem[0].[0]\n"
+ "tag.mem[0].@foo.mem[0].[0]\n"
+ "tag.mem[0].mem.@foo.mem[0].[0]\n"
+ "tag.mem[0].1.@foo.mem[0].[0]\n"
+ "tag.mem[0].[0].@foo.mem[0].[0]\n\n\n"
+ "tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}