// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<tag>(?:[a-zA-Z]\w*|_\w+))(?<memspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?(?<metadataspec>(?:\s*\.\@(?<metadataid>(?:[a-zA-Z]\w*|_\w+))(?<metadatamemspec>(?:(?:(?:\s*\.(?:[a-zA-Z]\w*|_\w+)|(?:\s*\[(?:[^,\]]+)(?:,(?:[^,\]]+))*\]))*)(?:(?:\s*\.\d+|\.\s*(?:\s*\[(?:[^,\]]+)\]))?)))?))?$").unwrap();
let string = "tag
tag.mem
tag.1
tag.[0]
tag[0]
tag[0].mem
tag[0].1
tag[0].[0]
tag.mem
tag.mem.mem
tag.mem.1
tag.mem.[0]
tag.mem[0]
tag.mem[0].mem
tag.mem[0].1
tag.mem[0].[0]
tag.@foo.mem[0].[0]
tag.mem.@foo.mem[0].[0]
tag.1.@foo.mem[0].[0]
tag.[0].@foo.mem[0].[0]
tag[0].@foo.mem[0].[0]
tag[0].mem.@foo.mem[0].[0]
tag[0].1.@foo.mem[0].[0]
tag[0].[0].@foo.mem[0].[0]
tag.mem.@foo.mem[0].[0]
tag.mem.mem.@foo.mem[0].[0]
tag.mem.1.@foo.mem[0].[0]
tag.mem.[0].@foo.mem[0].[0]
tag.mem[0].@foo.mem[0].[0]
tag.mem[0].mem.@foo.mem[0].[0]
tag.mem[0].1.@foo.mem[0].[0]
tag.mem[0].[0].@foo.mem[0].[0]
tag .mem [ tag.@foo ] .mem .@foo .mem [ 0 ] .a .1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}