const regex = new RegExp('\\w+\\s*\\((?P<parameters>(?:(?:(?:[^()]*\\([^()]*\\))+|[^()]*)(?:,(?!\\s*\\))|(?=\\))))*)\\)', 'gm')
const str = `a(1)
a(b())
example( other(1), 123, [25]).othermethod(456)
a(b(c()))
a(")")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}