import re
regex = re.compile(r"\w+\s*\((?P<parameters>(?:(?:(?:[^()]*\([^()]*\))+|[^()]*)(?:,(?!\s*\))|(?=\))))*)\)", flags=re.MULTILINE)
test_str = ("a(1)\n\n"
"a(b())\n\n"
"example( other(1), 123, [25]).othermethod(456)\n\n"
"a(b(c()))\n\n"
"a(\")\")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")