$re = '/\w+\s*\((?P<parameters>(?:(?:(?:[^()]*\([^()]*\))+|[^()]*)(?:,(?!\s*\))|(?=\))))*)\)/m';
$str = 'a(1)
a(b())
example( other(1), 123, [25]).othermethod(456)
a(b(c()))
a(")")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);