#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/imgur\.com\/a\/(.*?)(?:\/)?)"
Local $sString = "http://imgur.com/a/ksU2j/embed#0" & @CRLF & _
"http://imgur.com/a/ksU2j#0" & @CRLF & _
"http://imgur.com/a/ksU2j" & @CRLF & _
"http://imgur.com/a/ksU2j/all" & @CRLF & _
"http://imgur.com/a/ksU2j/embed?backgrou...umbs=true" & @CRLF & _
"" & @CRLF & _
"how to get id & full url?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")