import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/imgur\\.com\\/a\\/(.*?)(?:\\/)?)";
final String string = "http://imgur.com/a/ksU2j/embed#0\n"
+ "http://imgur.com/a/ksU2j#0\n"
+ "http://imgur.com/a/ksU2j\n"
+ "http://imgur.com/a/ksU2j/all\n"
+ "http://imgur.com/a/ksU2j/embed?backgrou...umbs=true\n\n"
+ "how to get id & full url?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}