$re = '/(https?:\/\/imgur\.com\/a\/(.*?)(?:\/)?)/';
$str = 'http://imgur.com/a/ksU2j/embed#0
http://imgur.com/a/ksU2j#0
http://imgur.com/a/ksU2j
http://imgur.com/a/ksU2j/all
http://imgur.com/a/ksU2j/embed?backgrou...umbs=true
how to get id & full url?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);