using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/imgur\.com\/a\/(.*?)(?:[#\/].*|$))";
string input = @"http://imgur.com/a/ksU2j/embed#0
http://imgur.com/a/ksU2j#0
http://imgur.com/a/ksU2j
http://imgur.com/a/ksU2j/all
http://imgur.com/a/ksU2j/embed?backgrou...umbs=true
how to get id & full url?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}