package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/imgur\.com\/a\/(.*?)(?:[#\/].*|$))`)
var str = `http://imgur.com/a/ksU2j/embed#0
http://imgur.com/a/ksU2j#0
http://imgur.com/a/ksU2j
http://imgur.com/a/ksU2j/all
http://imgur.com/a/ksU2j/embed?backgrou...umbs=true
how to get id & full url?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}