import Foundation
let pattern = ##"(https?:\/\/imgur\.com\/a\/(.*?)(?:[#\/].*|$))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
http://imgur.com/a/ksU2j/embed#0
http://imgur.com/a/ksU2j#0
http://imgur.com/a/ksU2j
http://imgur.com/a/ksU2j/all
http://imgur.com/a/ksU2j/embed?backgrou...umbs=true
how to get id & full url?
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)