#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((?!<[^<]*>)[\s\S])*$"
Local $sString = "no elements" & @CRLF & _
"<div>an element</div>" & @CRLF & _
"some text with <b>an element</b>" & @CRLF & _
"more text > with no elements"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")