re = /^((?!<[^<]*>)[\s\S])*$/
str = 'no elements
<div>an element</div>
some text with <b>an element</b>
more text > with no elements'
# Print the match result
str.match(re) do |match|
puts match.to_s
end