using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!<[^<]*>)[\s\S])*$";
string input = @"no elements
<div>an element</div>
some text with <b>an element</b>
more text > with no elements";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}