const regex = /\d+[\r\n](\d+:\d+:\d+,\d+ --> \d+:\d+:\d+,\d+)[\r\n]((.+\r?\n)+(?=(\r?\n)?))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+[\\r\\n](\\d+:\\d+:\\d+,\\d+ --> \\d+:\\d+:\\d+,\\d+)[\\r\\n]((.+\\r?\\n)+(?=(\\r?\\n)?))', 'g')
const str = `1
00:02:17,440 --> 00:02:20,375
Senator, we're making
our final approach into Coruscant.
2
00:02:20,476 --> 00:02:22,501
Very good, Lieutenant.
3
00:03:20,476 --> 00:03:22,501
こんにちは
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}