import re
regex = re.compile(r"\d+[\r\n](\d+:\d+:\d+,\d+ --> \d+:\d+:\d+,\d+)[\r\n]((.+\r?\n)+(?=(\r?\n)?))")
test_str = ("1\n"
"00:02:17,440 --> 00:02:20,375\n"
"Senator, we're making\n"
"our final approach into Coruscant.\n\n"
"2\n"
"00:02:20,476 --> 00:02:22,501\n"
"Very good, Lieutenant.\n\n"
"3\n"
"00:03:20,476 --> 00:03:22,501\n"
"こんにちは\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")