re = /\d+[\r\n](\d+:\d+:\d+,\d+ --> \d+:\d+:\d+,\d+)[\r\n]((.+\r?\n)+(?=(\r?\n)?))/
str = '1
00:02:17,440 --> 00:02:20,375
Senator, we\'re making
our final approach into Coruscant.
2
00:02:20,476 --> 00:02:22,501
Very good, Lieutenant.
3
00:03:20,476 --> 00:03:22,501
こんにちは
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end