re = /@\S+|(_)/m
str = '_
lol_
@username_
lol@username_
lol_@username
lol_@username_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end