package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)400 people drive dark blue cars|400 people drive cars`)
var str = `400 people drive dark blue cars
400 people drive cars`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}