re = /400 people drive dark blue cars|400 people drive cars/m
str = '400 people drive dark blue cars
400 people drive cars'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end