$re = '/[1-9]\d{0,4}\s+((optional|etc)\s+)?(\w+\s+){1,3}(suffix|end)\s+((optional|etc))?/m';
$str = '123 two unknown suffix optional';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);