#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-zA-Z0-9\._%+-]+@[a-zA-Z0-9\.-]+\.[a-zA-Z]{2,4})[\ \:\;\?\!]?"
Local $sString = "I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark." & @CRLF & _
"1.aasdf@blub.de" & @CRLF & _
"I work with 2.blub@blub.de gnuwin and tried grep but didn't got the right result" & @CRLF & _
"I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text " & @CRLF & _
"3.blub@blub.de file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark. I work with gnuwin and 4.blub.blub@blub.sdff de tried grep but didn't got the right result" & @CRLF & _
"5.blub@blub.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")