# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9\._%+-]+@[a-zA-Z0-9\.-]+\.[a-zA-Z]{2,4})[\ \:\;\?\!]?"
test_str = ("I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark.\n"
"1.aasdf@blub.de\n"
"I work with 2.blub@blub.de gnuwin and tried grep but didn't got the right result\n"
"I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text \n"
"3.blub@blub.de file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark. I work with gnuwin and 4.blub.blub@blub.sdff de tried grep but didn't got the right result\n"
"5.blub@blub.de")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.