using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9\._%+-]+@[a-zA-Z0-9\.-]+\.[a-zA-Z]{2,4})[\ \:\;\?\!]?";
string input = @"I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark.
1.aasdf@blub.de
I work with 2.blub@blub.de gnuwin and tried grep but didn't got the right result
I got this plain text from wich I want to delete all email adresses (or replace by E). I want to keep everything else in the text
3.blub@blub.de file. The email adresses can be followed by a space, colon, semicolon, question or exclamation mark. I work with gnuwin and 4.blub.blub@blub.sdff de tried grep but didn't got the right result
5.blub@blub.de";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}