package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\sNew User:\s(.+?_user)\sfunction:\s(auditor|auditor2)\s`)
var str = `blablabla bla bla blabla New User: John_user function: auditor blablablablabl bla blab New User: Do_user function: auditor2 blablabl blablb...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}