const regex = /\sNew User:\s(.+?_user)\sfunction:\s(auditor|auditor2)\s/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\sNew User:\\s(.+?_user)\\sfunction:\\s(auditor|auditor2)\\s', 'gs')
const str = `blablabla bla bla blabla New User: John_user function: auditor blablablablabl bla blab New User: Do_user function: auditor2 blablabl blablb...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}