const regex = /\s*(?<!\w)(?:at|ax|CL|OZ|Gm|Kg|C100|-1\.00)(?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?<!\\w)(?:at|ax|CL|OZ|Gm|Kg|C100|-1\\.00)(?!\\w)', 'gm')
const str = `This is at Sample ax Text, which CL is OZ better and cleaned Gm, where C100 is not equal to -1.00. This is messy text Kg.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);