import re
regex = re.compile(r"\s*(?<!\w)(?:at|ax|CL|OZ|Gm|Kg|C100|-1\.00)(?!\w)", flags=re.MULTILINE)
test_str = "This is at Sample ax Text, which CL is OZ better and cleaned Gm, where C100 is not equal to -1.00. This is messy text Kg."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)