re = /\s*(?<!\w)(?:at|ax|CL|OZ|Gm|Kg|C100|-1\.00)(?!\w)/m
str = 'This is at Sample ax Text, which CL is OZ better and cleaned Gm, where C100 is not equal to -1.00. This is messy text Kg.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result