using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<OrigPrefix>.*?)\s+(?<OrigGarbage>.*\[operationlog.LogSender\])\s+(?<OrigLevel>.*?)\s+(?<OrigOperation>.*?)\s+(?<OrigMessage>.*)";
string input = @"00:05:01,734 INFO [ajp-10.92.36.4-8009-187] [operationlog.LogSender] info stateNotificationDeletion eventTime:Mon Mar 23 00:05:02 CET 2015 source:""1.2249.2251.2427.2429.27615.27617.28307.28311"" destination:(long)27715 result:null messageId:14865920 changeId:null
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}