import Foundation
let pattern = #"(?<OrigPrefix>.*?)\s+(?<OrigGarbage>.*\[operationlog.LogSender\])\s+(?<OrigLevel>.*?)\s+(?<OrigOperation>.*?)\s+(?<OrigMessage>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
00:05:01,734 INFO [ajp-10.92.36.4-8009-187] [operationlog.LogSender] info stateNotificationDeletion eventTime:Mon Mar 23 00:05:02 CET 2015 source:"1.2249.2251.2427.2429.27615.27617.28307.28311" destination:(long)27715 result:null messageId:14865920 changeId:null
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}