re = /(?<OrigPrefix>.*?)\s+(?<OrigGarbage>.*\[operationlog.LogSender\])\s+(?<OrigLevel>.*?)\s+(?<OrigOperation>.*?)\s+(?<OrigMessage>.*)/
str = '00:05:01,734 INFO [ajp-10.92.36.4-8009-187] [operationlog.LogSender] info stateNotificationDeletion eventTime:Mon Mar 23 00:05:02 CET 2015 source:"1.2249.2251.2427.2429.27615.27617.28307.28311" destination:(long)27715 result:null messageId:14865920 changeId:null
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end