using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\.(*SKIP)(*FAIL)|\|~s";
string input = @"match bar only if there is foo behind it so here's bar";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}