$re = '/\\\\\\\\.(*SKIP)(*FAIL)|\|~s/bar';
$str = 'match bar only if there is foo behind it so here\'s bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);