package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\\\.(*SKIP)(*FAIL)|\|~s`)
var str = `match bar only if there is foo behind it so here's bar`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}