#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9])+$"
Local $sString = "1234" & @CRLF & _
"4775" & @CRLF & _
"773" & @CRLF & _
"" & @CRLF & _
"6 S Surfway" & @CRLF & _
"70 N Grove St" & @CRLF & _
"1661-114 Old Country Rd" & @CRLF & _
"" & @CRLF & _
"Calverton " & @CRLF & _
"Freeport " & @CRLF & _
"Riverhead "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")