package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9])+$`)
var str = `1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}