using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9])+$";
string input = @"1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}