using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(START[a-z\s\d]+)";
string input = @"START 123 456 789 START abc def ghi START xyz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}