package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(START[a-z\s\d]+)`)
var str = `START 123 456 789 START abc def ghi START xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}