$re = '/(START[a-z\s\d]+)/';
$str = 'START 123 456 789 START abc def ghi START xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);