using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Z]+\. ?)+$(?<! )";
string input = @"Ing
Ing.
.Ing.
Xx Yy.
XX. YY.
XX.YY.
XX.YY. ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}