re = /^(?:[A-Z]+\. ?)+$(?<! )/mi
str = 'Ing
Ing.
.Ing.
Xx Yy.
XX. YY.
XX.YY.
XX.YY. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end