import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\"Level\\s\\d+\")(?<!\")\"?Level\\s\\d+\"?";
final String string = "This is a test with various \"Level 2\" and Level 5 and stuff.\n\n"
+ "Not sure how to treat \"Level 2 or Level 5\" though.\n\n"
+ "Also capturing Level 12 would be nice I guess? (Not \"Level 12\" of course though)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}