$re = '/(?!"Level\s\d+")(?<!")"?Level\s\d+"?/m';
$str = 'This is a test with various "Level 2" and Level 5 and stuff.
Not sure how to treat "Level 2 or Level 5" though.
Also capturing Level 12 would be nice I guess? (Not "Level 12" of course though)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);