using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$";
string substitution = @"";
string input = @"7491260006";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}