re = /^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$/
str = '7491260006'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result