import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=([b]*[a]){3})(?=([a]*[b]){3})[ab]+";
final String string = "abab\n"
+ "aabbb\n"
+ "aaabb\n\n"
+ "abbaba\n"
+ "aaaabbb\n"
+ "abbabababbababbababab\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}